Zmiana PHP na 5.5

Wróc do listy tematów
  • Przejdź do profilu użytkowika
  • Nowicjusz
  • Członek społeczności
  • Postów: 14
  • Rejestracja: 01.04.2012
Data: 22 September 2015 13:09

Witam,
W najbliższym czasie mój serwer przestanie wspierać PHP 5.3
Po pierwszych testach na PHP 5.5 widzę, że nasz sklep postawiony na Geko 1.4.0 będzie miał problemy.
Błędy widoczne na pierwszy rzut oka to

Strona produktu:
Warning: Illegal string offset ‘small’ in /home/isp11079/domains/horse.shop.pl/public_html/plugin/frontend/core/product/model/product.php on line 891
Warning: Illegal string offset ‘normal’ in /home/isp11079/domains/horse.shop.pl/public_html/plugin/frontend/core/product/model/product.php on line 892
Warning: Illegal string offset ‘orginal’ in /home/isp11079/domains/horse.shop.pl/public_html/plugin/frontend/core/product/model/product.php on line 893

Koszyk:
Strict Standards: Declaration of FE_Form::Validate() should be compatible with FE_Container::Validate() in /home/isp11079/domains/horse.shop.pl/public_html/lib/FormEngine/Elements/FE_Form.php on line 17 Strict Standards: Only variables should be assigned by reference in /home/isp11079/domains/horse.shop.pl/public_html/plugin/super/core/inpost/model/inpost.php on line 254 Strict Standards: Only variables should be assigned by reference in /home/isp11079/domains/horse.shop.pl/public_html/plugin/super/core/inpost/model/inpost.php on line 262

Admin:
Brak możliwości załadowania list produktów, listy zamówień

Strict Standards: Declaration of FE_Form::Validate() should be compatible with FE_Container::Validate() in /home/isp11079/domains/horse.shop.pl/public_html/lib/FormEngine/Elements/FE_Form.php on line 17

Czy w jakiś nieskomplikowany sposób można dostroić tą wersję Gego do współpracy z PHP 5.5?

  • Przejdź do profilu użytkowika
  • Administrator
  • Postów: 567
  • Rejestracja: 04.07.2012
Data: 22 September 2015 20:59

Cóż to za dziwny serwer że php 5.3 przestanie działać?

----------------------

Sklepy na Gekosale i Wellcommerce, zapraszam: wrizu.pl
Potrzebujesz sklepu lub jego modyfikacji, napisz:
Pomożemy w każdej, również najdrobniejszej sprawie.

  • Przejdź do profilu użytkowika
  • Nowicjusz
  • Członek społeczności
  • Postów: 14
  • Rejestracja: 01.04.2012
Data: 23 September 2015 17:11

Takie info przyszło od admina:

W związku z brakiem wsparcia dla PHP w wersji 5.2 oraz 5.3, uprzejmie informujemy, że z dniem 17.11.2015 nastąpi ich zmiana na wersję 5.5, która to dodatkowo stanie się wersją domyślną. Dlatego też prosimy o sprawdzenie funkcjonowania Państwa serwisów na nowszej wersji oraz wprowadzenie ewentualnych, wymaganych zmian celem ich dostosowania. Jednocześnie zaznaczamy, że domeny działające pod wersjami PHP 5.4 oraz 5.6 zachowają swoją obecną konfigurację. Po 17.11.2015 nie będą Państwo mieli możliwości włączenia wersji PHP 5.2 oraz 5.3.

  • Przejdź do profilu użytkowika
  • Member
  • Postów: 53
  • Rejestracja: 26.05.2014
Data: 01 Październik 2015 00:37

No to 5.4, na tym sklep pójdzie spokojnie.

  • Przejdź do profilu użytkowika
  • Nowicjusz
  • Członek społeczności
  • Postów: 14
  • Rejestracja: 01.04.2012
Data: 03 Październik 2015 19:26

Po przestawieniu PHP na 5.4 wyświetla takie same błędy jak na 5.5

Data: 20 Październik 2015 08:24

i jak, jest jakaś możliwość przystosowania do PHP 5.5?

----------------------

Sprzęt Sportowy - http://www.sprzet-sportowy.com.pl

  • Przejdź do profilu użytkowika
  • Sr. Member
  • Członek społeczności
  • Postów: 111
  • Rejestracja: 30.09.2012
Data: 23 Październik 2015 19:01

Sklep nie działa na php 5.4
U mnie np. nie wyświetlają się zdjecia produktów.

  • Przejdź do profilu użytkowika
  • Member
  • Postów: 63
  • Rejestracja: 04.10.2012
Data: 05 Listopad 2015 17:08

Witam,
czy ktoś odpłatnie poprawiłby to, by zdjęcia w karcie produktu były wyświetlane w wersji PHP 5.4
Mowa o wersji Gekosale 1.4.3

Chcę zmienić hosting na VPS i dziś dostałem taką odpowiedź od admina iq.pl
“nieco problematyczne może być ustawienie wersji PHP 5.3, która nie jest obecnie wspierana przez nowsze systemy operacyjne. Czy Pana strony działają na wersji PHP 5.4?”

Niestety, nie działają:(( - nie widać zdjęć na karcie produktu. Reszta wydaje się działa normalnie.
Pozdrawiam wszystkich.

----------------------

http://www.silnikowiec.pl

  • Przejdź do profilu użytkowika
  • Sr. Member
  • Członek społeczności
  • Postów: 179
  • Rejestracja: 29.02.2012
Data: 09 Listopad 2015 02:10

Nie rozumiem u mnie na 5.4 chodzą geko 1.4 i 2.
Upss , jednak u mnie też na 5.4 nie wyświetlają sie zdjęcia produktów…

Edytowany: 09 Listopad 2015 03:00 przez przemek

----------------------

http://forum-zdrowieiuroda.keed.pl
http://www.forever.iq.pl
http://taniechwilowki.net/
http://ranking-chwilowek.net/

  • Przejdź do profilu użytkowika
  • Sr. Member
  • Partner społeczności
  • Postów: 470
  • Rejestracja: 06.02.2012
Data: 23 Listopad 2015 12:18

Niedawno zajmowałem się poprawkami dotyczącymi przystosowania Gekosale 1.4.3 dla PHP 5.5. Jeżeli ktoś jest zainteresowany zleceniem takiej modyfikacji to zapraszam do kontaktu mailowego.

----------------------

Zapraszam na http://mygekosale.pl gdzie znajduje się pełna oferta Modułów dla Gekosale 1.4 oraz 2.0 moduły dla Gekosale
Polecam poprawione Gekosale 2

  • Przejdź do profilu użytkowika
  • Nowicjusz
  • Członek społeczności
  • Postów: 4
  • Rejestracja: 05.01.2016
Data: 12 Styczeń 2016 12:24

Chyba będę się musiał odezwać bo mam podobny problem na 5.4 mi nie działa ;x nie wiem juz sam o co chodzi.

----------------------

Wykonujemy strony internetowe

 
       
 
Wpisz szukaną frazę oraz wybierz post
Zaawansowane wyszukiwanie
  • Nowe posty
  • Gorący temat z nowymi postami
  • Zamknięty temat
  • Nowa ankieta
  • Temat przyklejony
  • Brak nowych postów
  • Gorący temat bez nowych postów
  • Temat przeniesiony
  • Stara ankieta
  • Pilne ogłoszenie
Nowi użytkownicy:
  • Zarejestrowanych: 43026
  • Zalogowanych: 0
  • Anonimowych: 0
  • Gości: 38
  • Tematów: 3556
  • Odpowiedzi: 15437
  • Postów: 18993
Aktywni użytkownicy: